Home  


  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: KOI Talk: Pond Water Quality:
algae problem

 




Web Services & EcommercePurchase Printer Toner and Ink (Original and Remanufactured) Online  - Antivirus Online



 


john labu
New User

Jan 3, 2010, 2:20 AM

Post #1 of 5 (4503 views)
Shortcut
algae problem Can't Post

hi....
i need some help here... my pond water is clear but the problem is, there are thick algae sticking on my waterfall wall .... how to get rid of it... really wish if somebody could help me here.. thanks..


KoiAnswers
Koi Kichi

Jan 5, 2010, 5:50 AM

Post #2 of 5 (4413 views)
Shortcut
Re: [john labu] algae problem [In reply to] Can't Post

Hi John,
Many ways to combat against algae. I know at times it can be an ugly site. I have done many things actually, but I reckon the best is to get yourself a water jet, and weekly blast the area that have these unwanted algaes. It will take you no more than 5 minutes to do this.

Regards,



lamig747
User


Jan 6, 2010, 12:15 AM

Post #3 of 5 (4352 views)
Shortcut
Re: [john labu] algae problem [In reply to] Can't Post

Its a universal problem to have. If u dnt want to see it, they are easily removed by brushing lightly. Learned this from hotels esp in Bali who are full of waterfalls in every corner.


dheensay
User


Jan 15, 2010, 5:53 AM

Post #4 of 5 (4204 views)
Shortcut
Re: [lamig747] algae problem [In reply to] Can't Post

I have got carpet (short) algae growing on the walls of my pond. I dont mind this at all....and neither do the koi, who enjoy chomping on it.

However, for about a week now, i have noticed there is also some string like algae floating below the water. This is already getting stuck in my SS. It seems to be increasing and i can sense that the koi are not happy about it. What can i do to eliminate them?

Abang shukri, you had previously mentioned using S1. Will this do the trick? I have no QT.

KAAJ

www.dheensay.com for casual outdoor & banquet furniture!


stevie
User

Jan 15, 2010, 10:30 AM

Post #5 of 5 (4188 views)
Shortcut
Re: [dheensay] algae problem [In reply to] Can't Post

Hi KAAJ,

Is yours string like algae black in color? I once had plenty and it clogged my filters. Later I discovered that it was some mud/soil that I accidentally introduced to my pond.

Stevie

 
 
 



Search for (options) Back to Koi.com.my Main Page

  Disclaimer  Privacy Statement     
Copyright 2001~ 2002 Hileytech Sdn Bhd , All Rights Reserved.  
No part of the forum postings can be copied without prior permission from Hileytech Sdn Bhd and the Author of the Posting.
For comments and Suggestion, Please contact the Webmaster at koi@hileytech.com